MPLABXのCode Configuratorでライブラリバージョンが一致しない

自分用のメモなので走り書き程度に。

ネット上で公開されているMPLABXのプロジェクトファイルをダウンロードしてきて
MPLABXからCode Configuratorを起動したときに下のようなメッセージが出て起動できなかった。

INFO: com.microchip.mcc.mcu8.Mcu8PeripheralLibrary v1.65.1
SEVERE: Unable to find requested library version: com.microchip.mcc.mcu8.Mcu8PeripheralLibrary v1.65.1
WARNING: Unable to load project, the following libraries cannot be found:
WARNING: com.microchip.mcc.mcu8.Mcu8PeripheralLibrary v1.65.1
WARNING: All library versions are available for download on the MCC website. www.microchip.com/mcc
INFO: Stop MCC

どうやら、ダウンロードしてきたプロジェクトで使われているPeripheralLibraryのバージョンと
インストールされている環境でのバージョンが異なっているのが原因らしい。
対処法は以下の通り。

Advertisement


1.https://www.microchip.com/mplab/mplab-code-configurator に行って必要なバージョンのDevice LibrarieをDL。
2.Tools->Options->PluginsのCode ConfiguratorタブのOpenLibraryをクリック
3.フォルダが開くのでそこにDLした****.jarファイルをコピー
4.Mplabを再起動。

確認バージョン
MPLABX IDE V5.10
Code Configurator V3.66









コメント
コメントする








   

calendar

S M T W T F S
    123
45678910
11121314151617
18192021222324
25262728293031
<< August 2019 >>

RSS Readerに登録


follow us in feedly

にほんブログ村 その他趣味ブログ 電子工作へ
にほんブログ村


アマチュア無線 ブログランキングへ






製作物紹介リンク

メールフォーム

秋葉原ショールームのご案内

selected entries

categories

archives

links

profile

search this site.

others

mobile

qrcode

powered

無料ブログ作成サービス JUGEM